Welcome to Media Center Master!
A powerful solution for mastering your digital media library.
Supporting Emby, Kodi/XBMC/OSMC, Plex, Windows Media Center, and more!

Home Download Gallery Wiki Issue Tracker Licensing Forums

   FAQ  •  Search •  Login •  Register     
It is currently October 16th, 2019, 10:51 am

All times are UTC - 7 hours [ DST ]



Post new topic Reply to topic  [ 22 posts ]  Go to page Previous  1, 2, 3  Next
Author Message
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 1st, 2019, 6:45 pm 
Offline
Developer/Owner
User avatar

Joined: May 1st, 2009, 10:12 am
Posts: 11610
Location: Meridian, ID, USA
Try again.

It's available on auto-update and confirmed by the community. You may need to temporarily disable your security software if it's interfering with the update process.

_________________
Peter Souza IV
stable version 2.19.23119.1014 / August 19th, 2019
Media Center Master on Facebook!


 Profile  
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 1st, 2019, 9:53 pm 
Offline
Flash Video

Joined: March 23rd, 2011, 2:48 pm
Posts: 20
Shut down the PC, booted it back up, disabled Avast and started MCM, made sure that in the settings the Using auto-update is ticked. Tried again but no updating the program. I never had a problem in the past here is a picture of the about box.

Image


 Profile  
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 2nd, 2019, 1:14 am 
Offline
Community Support
User avatar

Joined: September 10th, 2010, 8:36 am
Posts: 2684
Location: Washington
One2go wrote:
Shut down the PC, booted it back up, disabled Avast and started MCM, made sure that in the settings the Using auto-update is ticked. Tried again but no updating the program. I never had a problem in the past here is a picture of the about box.

Image


You can try the updated installer as it is newer than your installation and see if it will auto update.

viewtopic.php?f=2&t=19613

_________________
Support Information
Help-Support Information, Click "Copy All", "Yes", "OK", "Close" and paste in forum

Debug logging
Help-Debug-Show developer-level debug messaging

stable version 2.19 (build 23119.1014) / August 19th, 2019


 Profile  
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 2nd, 2019, 9:28 am 
Offline
Flash Video

Joined: March 23rd, 2011, 2:48 pm
Posts: 20
Thanks for the suggestion but before using the new installer I tried again today and it updated with 12 new files here is picture of the about box.

Image


 Profile  
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 2nd, 2019, 9:40 am 
Offline
Developer/Owner
User avatar

Joined: May 1st, 2009, 10:12 am
Posts: 11610
Location: Meridian, ID, USA
One2go wrote:
Thanks for the suggestion but before using the new installer I tried again today and it updated with 12 new files here is picture of the about box.

Image
Congrats, this is the current version -- it should restore functionality with the TVDB API. :thumbsup:

_________________
Peter Souza IV
stable version 2.19.23119.1014 / August 19th, 2019
Media Center Master on Facebook!


 Profile  
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 5th, 2019, 4:56 pm 
Offline
Original BluRay

Joined: November 16th, 2010, 5:29 am
Posts: 395
I'm not sure if this is related to the API issue, but I've noticed now that when I come home from work, all my shows show a status of "Upcoming". If i do an "update score/status" I see messages that nothing has changed and status is still "Upcoming". So I shut down MCM and relaunch, then do another "update score/status" and all the dates come back. The next day, when I get home from work, they are back to "Upcoming".


 Profile  
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 5th, 2019, 5:06 pm 
Offline
Community Support
User avatar

Joined: September 10th, 2010, 8:36 am
Posts: 2684
Location: Washington
muzicman61 wrote:
I'm not sure if this is related to the API issue, but I've noticed now that when I come home from work, all my shows show a status of "Upcoming". If i do an "update score/status" I see messages that nothing has changed and status is still "Upcoming". So I shut down MCM and relaunch, then do another "update score/status" and all the dates come back. The next day, when I get home from work, they are back to "Upcoming".


Yep it would appear when api v2 as re-applied this issue returned.

2.19.21419.1073

_________________
Support Information
Help-Support Information, Click "Copy All", "Yes", "OK", "Close" and paste in forum

Debug logging
Help-Debug-Show developer-level debug messaging

stable version 2.19 (build 23119.1014) / August 19th, 2019


 Profile  
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 5th, 2019, 5:40 pm 
Offline
Community Support
User avatar

Joined: September 10th, 2010, 8:36 am
Posts: 2684
Location: Washington
Not sure if it is MCM or TVDB issue. Trying to process a series that mis-identified or ID has changed as all images and metadata were correct.

Code:
4:34 PM ::  tv  db   Now working on Z:\ServerFolders\Videos\TV Series\Forever (2014)
4:34 PM ::  tv  db   Fetching data for season 1, episode 1
4:34 PM ::  tv  db   Episode doesn't seem to exist
4:34 PM ::  tv  db   Done with this episode!
4:34 PM ::  tv  db   Now working on Z:\ServerFolders\Videos\TV Series\Forever (2014)
4:34 PM :: [16:34:48.393] Fetching URL (GET):  https://api.thetvdb.com/series/281535
4:34 PM :: [16:34:48.395] DEBUG:  Comm adapted to thetvdb.com API
4:34 PM :: [16:34:48.437] DEBUG:  Newtonsoft.Json.JsonReaderException: Error reading JObject from JsonReader. Current JsonReader item is not an object: StartArray. Path '', line 1, position 1.
4:34 PM :: [16:34:48.437] DEBUG:  Z:\ServerFolders\Videos\TV Series\Forever (2014)\Season 1\Forever.S01E01.Pilot.mp4
4:34 PM ::  tv  db   Fetching data for season 1, episode 1
4:34 PM :: [16:34:48.507] Fetching URL (GET):  https://api.thetvdb.com/series/281535/episodes?page=1
4:34 PM :: [16:34:48.508] DEBUG:  Comm adapted to thetvdb.com API
4:34 PM :: [16:34:48.541] DEBUG:  Newtonsoft.Json.JsonReaderException: Error reading JObject from JsonReader. Current JsonReader item is not an object: StartArray. Path '', line 1, position 1.
4:34 PM ::  tv  db   Episode doesn't seem to exist
4:34 PM ::  tv  db   Done with this episode!
4:34 PM :: [16:34:48.555] Fetching URL (GET):  https://api.thetvdb.com/series/281535/episodes?page=1
4:34 PM :: [16:34:48.556] DEBUG:  Comm adapted to thetvdb.com API
4:34 PM :: [16:34:48.581] DEBUG:  Newtonsoft.Json.JsonReaderException: Error reading JObject from JsonReader. Current JsonReader item is not an object: StartArray. Path '', line 1, position 1.
4:34 PM :: [16:34:48.581] DEBUG:  Fetched episode: Z:\ServerFolders\Videos\TV Series\Forever (2014)\Season 1\Forever.S01E01.Pilot.mp4

_________________
Support Information
Help-Support Information, Click "Copy All", "Yes", "OK", "Close" and paste in forum

Debug logging
Help-Debug-Show developer-level debug messaging

stable version 2.19 (build 23119.1014) / August 19th, 2019


 Profile  
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 7th, 2019, 5:42 pm 
Offline
Original BluRay

Joined: July 29th, 2011, 8:25 am
Posts: 208
I've noticed it's not grabbing TV episode artwork. The images are on the TVDB site, I checked. The artworks.thetvdb URL looks to be directed at "banners", not sure if that's correct. I only collect episode & season poster artwork. Using v219 21419.1073

Image

Image


 Profile  
 Post subject: Re: TVDB Site Changed - Processing/API Issues?
PostPosted: August 8th, 2019, 4:28 pm 
Offline
Community Support
User avatar

Joined: September 10th, 2010, 8:36 am
Posts: 2684
Location: Washington
To me it would appear the url for images has changed or rolledback. Change artworks to www.

Code:
https://www.thetvdb.com/banners/episodes/259866/4583505.jpg

_________________
Support Information
Help-Support Information, Click "Copy All", "Yes", "OK", "Close" and paste in forum

Debug logging
Help-Debug-Show developer-level debug messaging

stable version 2.19 (build 23119.1014) / August 19th, 2019


 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 22 posts ]  Go to page Previous  1, 2, 3  Next

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group



Copyright © 2009-2019, Media Center Master, Inc. All rights reserved.