Welcome to Media Center Master!
A powerful solution for mastering your digital media library.
Supporting Emby, Kodi/XBMC/OSMC, Plex, Windows Media Center, and more!

Home Download Gallery Wiki Issue Tracker Licensing Forums

   FAQ  •  Search •  Login •  Register     
It is currently January 29th, 2023, 10:49 pm

All times are UTC - 7 hours [ DST ]



Post new topic Reply to topic  [ 22 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject: Re: Unresponsive
PostPosted: October 31st, 2022, 9:45 am 
Offline
Xvid Movie

Joined: June 3rd, 2011, 4:48 pm
Posts: 47
v2.19 build 21019.821...just downloaded it from the site and installed it over my existing install, and disabled auto-update on the first launch. Good luck!


 Profile  
 Post subject: Re: Unresponsive
PostPosted: December 31st, 2022, 6:23 am 
Offline
Downloaded Clip

Joined: December 31st, 2022, 6:09 am
Posts: 1
cfilkins wrote:
SHoover wrote:
Yea, I've still been experiencing it. Not as often though. It was happening within 30 minutes of starting the program constantly, sometimes within like 5 minutes. But the last week or so maybe. shortly after I posted this It hasn't been occurring constantly. But it's definitely happening too often. I've uninstalled, then re-installed it. I've spun up a clean windows VM on one of my servers to see if it was something on that specific machine and it still happens so I dont think it's something on my end unless it's a setting I'm overlooking causing it.


FWIW, I'm having the same kind of issue, and it's been happening for a while now. Any assistance to either roll back to the prior version, or help to get it resolved in the current (or a new version) would be greatly appreciated.

And just to add my observations. MCM appears to be completely frozen and unresponsive. Yet when I use Task Manager to end the process, it appears to receive a request to shut down, and MCM appears to clean up and then close down. So there's some process in MCM that's hanging up the UI, but it'll still receive other requests in the background.


I'm running in debug mode and everytime there is a freeze/halt it's when handling the series.xml file and an exception header can be seen.

[14:11:56.158] DEBUG: Fatal error trying to read the XML data in "E:\TV\<some show>\series.xml":
System.Threading.ThreadAbortException: Thread was being aborted.
[14:11:56.168] DEBUG: NOT saved to cache (timeout during cache generation): E:\TV\<some show>

*** UPDATE ***
I found a workaround that seems to overcome the freezes, but not the slowness.
In the registry change MaxFetcherThreads value to 1 (default is 4 and greyed).
My best guess is that one of the fetcher threads hangs in the background and won't return the focus to the main app.


 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 22 posts ]  Go to page Previous  1, 2, 3

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group



Copyright © 2009-2023, Media Center Master, Inc. All rights reserved.