Welcome to Media Center Master!
A powerful solution for mastering your digital media library.
Supporting Emby, Kodi/XBMC/OSMC, Plex, Windows Media Center, and more!

Home Download Gallery Wiki Issue Tracker Licensing Forums

   FAQ  •  Search •  Login •  Register     
It is currently November 20th, 2018, 2:26 am

All times are UTC - 7 hours [ DST ]



Post new topic Reply to topic  [ 11 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Re: APPCRASH
PostPosted: October 11th, 2009, 4:37 pm 
Offline
Developer/Owner
User avatar

Joined: May 1st, 2009, 10:12 am
Posts: 11539
Location: Meridian, ID, USA
Can you download the full installer, install over your copy, and auto-update to the latest version?

_________________
Peter Souza IV
stable version 2.18.13818.935 / May 18th, 2018
Media Center Master on Facebook!


 Profile  
 Post subject: Re: APPCRASH
PostPosted: October 11th, 2009, 9:51 pm 
Offline
Developer/Owner
User avatar

Joined: May 1st, 2009, 10:12 am
Posts: 11539
Location: Meridian, ID, USA
I refreshed the entire autoupdate files and even built new versions of required assemblies. Try installing a fresh 1.16 and auto-updating again?

_________________
Peter Souza IV
stable version 2.18.13818.935 / May 18th, 2018
Media Center Master on Facebook!


 Profile  
 Post subject: Re: APPCRASH
PostPosted: October 12th, 2009, 8:36 am 
Offline
Developer/Owner
User avatar

Joined: May 1st, 2009, 10:12 am
Posts: 11539
Location: Meridian, ID, USA
Okay, I rebuilt every single file, changed all the versioning information, and re-released an auto-update for everything. In case that fails, though, I also rebuilt the installer. The same release notes will now download a 1.16b version (3.8 MB) that should work for you as well. Try that?

_________________
Peter Souza IV
stable version 2.18.13818.935 / May 18th, 2018
Media Center Master on Facebook!


 Profile  
 Post subject: Re: APPCRASH
PostPosted: October 13th, 2009, 6:01 am 
Offline
Developer/Owner
User avatar

Joined: May 1st, 2009, 10:12 am
Posts: 11539
Location: Meridian, ID, USA
If it crashes on startup, there's really only a few things that could be happening:

(a) you don't have all the required, updated files -- either because auto-update failed or you failed to run the install or auto-update as an Administrator. (Right-click, Run As Administrator -- simply logging in as an Administrator and running the program is not the same). This will cause a required assembly to fail to load and I will get an automated error report e-mailed to me.

(b) you don't have the .Net framework 3.5 installed (with SP1). Since you've run MCM before, this isn't the case, but I'm adding it up here for future readers.

(c) I accidentally compiled something for mixed CPU mode instead of x86. Mixed CPU mode doesn't like to run unless all of the assemblies are also compiled that way (and there are some functions that won't work that way). Usually this will cause a "side-by-side configuration error". I will check today in case one of the assemblies is misbehaving.

(d) you have a bad font file. I've seen this happen where you have a version of Tahoma that fails to render properly ('Bold' style not supported is what I usually see). This, too, will send me an automated error report and I haven't seen one in the past week regarding fonts, so I'm assuming that this isn't the case for you either.

Can you tell me if you're right-clicking and running MCM as an administrator (try it on the installer first)? Also, let me know if you're running 32-bit or 64-bit Windows. Finally, try a repair install on the .Net framework 3.5 SP1 (just install the .Net framework 3.5 SP1 again and it'll repair when you try to install). Believe it or not, this is sometimes a fix.

_________________
Peter Souza IV
stable version 2.18.13818.935 / May 18th, 2018
Media Center Master on Facebook!


 Profile  
 Post subject: Re: APPCRASH
PostPosted: October 13th, 2009, 8:12 am 
Offline
Developer/Owner
User avatar

Joined: May 1st, 2009, 10:12 am
Posts: 11539
Location: Meridian, ID, USA
I built another version that should resolve possibility (c) in case that was the issue. It's in auto-update as well as a new installer in the latest version (1.16.28609.439 setup c).

_________________
Peter Souza IV
stable version 2.18.13818.935 / May 18th, 2018
Media Center Master on Facebook!


 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ]  Go to page 1, 2  Next

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group



Copyright © 2009-2018, Media Center Master, Inc. All rights reserved.