Welcome to Media Center Master!
A powerful solution for mastering your digital media library.
Supporting Emby, Kodi/XBMC/OSMC, Plex, Windows Media Center, and more!

Home Download Gallery Wiki Issue Tracker Licensing Forums

   FAQ  •  Search •  Login •  Register     
It is currently December 14th, 2017, 2:38 pm

All times are UTC - 7 hours [ DST ]



Post new topic Reply to topic  [ 55 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: September 21st, 2016, 6:34 pm 
Offline
Community Support
User avatar

Joined: September 10th, 2010, 8:36 am
Posts: 2422
Location: Washington
If I understand everything correctly MCM will read the IDs from your nfo to fetch that id info from MCM fetchers. It will not import all metadata from nfo and write an xml.

_________________
Support Information
Help-Support Information, Click "Copy All", "Yes", "OK", "Close" and paste in forum

Debug logging
Help-Debug-Show developer-level debug messaging

stable version 2.17.26917.859 / September 26th, 2017


 Profile  
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: September 22nd, 2016, 1:08 am 
Offline
Xvid Movie

Joined: November 27th, 2013, 6:03 pm
Posts: 34
Why would it need to fetch when it's given the information it needs to write the xml? Seems unnecessary...

And the facts are (well certainly from my perspective) :
When I first started using this tool at end of 2012/start of 2013, I would first have Ember create and download the artwork of my choice (a feature MCM doesn't cater for). Open up MCM and perform a reinspect action (not fetch). MCM would then populate all the necessary details (from nfo, including Embers MPAA and certification style, which is country and rating, e.g. UK:15) and write xml.
Then towards end of 2013, Ember changed the id code line in the nfo to include both imdb and moviedb ids. MCM did not like this. If I removed the moviedb id from nfo and did a reinspect action, MCM would work exactly the same as above.
So I raised this as a potential bug, which Pete fixed in 2014. You even advised me to raise it as a bug in this same thread at the time.
MCM has since dealt with this handling style without issue until recently; about the time I resurrected this thread again.

So in brief, MCM worked in this way, stopped working, was fixed, worked again but has now stopped. I find it hard to believe it was a fluke that it's work twice...


 Profile  
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: February 20th, 2017, 4:04 pm 
Offline
Xvid Movie

Joined: November 27th, 2013, 6:03 pm
Posts: 34
I am sorry to resurrect this however with this feature not working, it is making my use of this program next to unusable. As you can see from the below quote from Pete many months ago, this feature was added and was working perfectly well.

Pete wrote:
Added support for Ember's version of movie.nfo, which deviates from Kodi/XBMC's specs. Thus this was a feature request, not a program defect/bug. Nonetheless, it's rolled into today's auto-update patch. :)


Would it be at all possible to get hold of an old version that I can test? It was only in a future release that this stopped working. As you can see from the start of this thread, I confirmed that a release early December 2014 had this feature working. Is there any chance of me laying my hand on a copy of that release?


 Profile  
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: February 20th, 2017, 4:11 pm 
Offline
Community Support
User avatar

Joined: September 10th, 2010, 8:36 am
Posts: 2422
Location: Washington
Only old releases available are on the download page.

_________________
Support Information
Help-Support Information, Click "Copy All", "Yes", "OK", "Close" and paste in forum

Debug logging
Help-Debug-Show developer-level debug messaging

stable version 2.17.26917.859 / September 26th, 2017


 Profile  
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: February 20th, 2017, 5:51 pm 
Offline
Xvid Movie

Joined: November 27th, 2013, 6:03 pm
Posts: 34
Thank you Doug!!!

I have proved that this worked in versions 2.13-2.15 but not 2.16.

Here is exactly what I did:
I uninstalled v 2.16 but kept the preferences file.
I copied 3 test moves across to my scan folder and deleted the movie.xml file leaving the video file, the .nfo and artwork created by Ember.
I then installed v 2.13 and opened it making sure it did not auto update.
MCM immediately retrieved the metadata from the Ember .nfo exactly per the information in that file.
I uninstalled and repeat through to v2.15 (deleting the movie.xml each time) and everything worked as I expected, retrieving the metadata from the Ember generated .nfo.
To be absolutely sure, I decided to once again delete the movie.xml and upgrade to v2.16. This time it DID NOT retrieve the information from the Ember generated .nfo and performing a refresh was not successful.

So I went back to v2.15 to be double sure and it still worked as expected.

I will therefore be sticking with v2.15 until this is fixed. Please could I have an ETA on the fix so that I know when to allow MCM to auto-update. Please do let me know what other information I can supply to help with the fix. Many thanks.

One thing to note is if I delete the movie.xmls and then open v2.15 and perform a "refresh from metadata (also re-inspects video file details)" it doesn't retrieve the video quality or details from the Ember .nfo but does the Score, Rating and Genre. If I remove the Ember .nfo, it doesn't retrieve this information either (as expected).
If I then perform a "Refresh and re-inspects video file details", MCM retrieves everything. It grabs the quality and video detail by using VidInfo plugin.

Added to the bug tracker here:
https://github.com/psouza4/mediacenterm ... ssues/1754


 Profile  
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: March 29th, 2017, 11:38 am 
Offline
Xvid Movie

Joined: November 27th, 2013, 6:03 pm
Posts: 34
Apologies if this is not the right place to ask this question, however is this bug being worked on?


 Profile  
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: April 13th, 2017, 11:03 am 
Offline
Developer/Owner
User avatar

Joined: May 1st, 2009, 10:12 am
Posts: 11315
Location: Meridian, ID, USA
I've updated the issue tracker directly with my comments.

_________________
Peter Souza IV
stable version 2.16.11117.1299 / April 21st, 2017
Media Center Master on Facebook!


 Profile  
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: April 14th, 2017, 3:59 pm 
Offline
Community Support
User avatar

Joined: September 10th, 2010, 8:36 am
Posts: 2422
Location: Washington
added this to the 2.16.10417.711

Issue 1754

_________________
Support Information
Help-Support Information, Click "Copy All", "Yes", "OK", "Close" and paste in forum

Debug logging
Help-Debug-Show developer-level debug messaging

stable version 2.17.26917.859 / September 26th, 2017


 Profile  
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: April 21st, 2017, 9:56 am 
Offline
Xvid Movie

Joined: November 27th, 2013, 6:03 pm
Posts: 34
Ok sorry but I am now really struggling...

I updated to the new version. Opened the tool and no files appear until I switched on auto-scan. So the files in the scan list were not automatically added.

So I deleted the scan folder (a network drive) and tried to readd but it didn't allow me too.

Reverted back to 2.15 as knew that was working but still couldn't add the drive...


 Profile  
 Post subject: Re: Conflict with Ember generated NFO
PostPosted: April 21st, 2017, 10:16 am 
Offline
Xvid Movie

Joined: November 27th, 2013, 6:03 pm
Posts: 34
Ignore! I hadn't checked UAC...

Also can report the fix is currently working :D

Thanks for your work Pete, much appreciated.


 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 55 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group



Copyright © 2009-2017, Media Center Master, Inc. All rights reserved.